Photo Mechanic 5

Why is there a message that Photo Mechanic 5 is not optimized for my Mac?

Last Updated -

This message may appear when you upgrade to macOS Mojave and launch Photo Mechanic 5 (or earlier). If you select OK, the alert message will disappear, and Photo Mechanic runs as expected.

Why you are seeing this message: While both 32 and 64-bit applications work on Mojave, future macOS updates will only support 64-bit applications. The warning message is to let you know that Photo Mechanic 5 is a 32-bit application that will no longer work with future macOS updates. This alert does not mean Photo Mechanic is incompatible with your computer.

Photo Mechanic 5 is compatible with macOS 10.6.8 (Snow Leopard) to Mojave.

Photo Mechanic 6 is a fully 64-bit application. You will not see this error message in Photo Mechanic 6. We offer a 30-day free trial if you would like to check it out.

 

Did you find this article helpful?

Still Need Help?

Still need help? Our support team is waiting to help you.