The modifier Key (Option key on Mac, Shift key on Windows) can be used to modify the operation of some dialog boxes.  

The Modifier Key can be used to suppress certain dialogue boxes and perform the operation from that dialogue box with the most recently used settings. This can be useful if you need to do a certain operation multiple times, but need to use the settings each time.

Menus

Holding down the modifier key while selecting these options from a menu or using the corresponding keyboard shortcut will suppress any dialogues or warnings and execute the command immediately:

  • File Menu:
    • Rename Photos
    • Copy/Move Photos
    • Save Photos As...
    • FTP Photos as.../Upload...
    • Delete Photos...
  • Image menu:
    • Applying Metadata (IPTC) Template
  • Edit menu: 
    • Paste Metadata Snapshot

Sequence

Holding down the modifier key anywhere you can set the Sequence variable allows you to Reset the Sequence variable back to "1". This is available in the following windows:

  • Rename
  • Save Photos As
  • Copy/Move Photos
  • Metadata Template
  • Metadata Info

Modifying buttons

Holding down the modifier key can modify the behavior of certain buttons in Photo Mechanic

  • Metadata Template window:
    • Clear becomes Options: you can now set which fields get cleared when the Clear button is selected
    • Copy to locations show table -> copy to loc shown/location
    • Sequence becomes Reset: see the 'Sequence' section above
  • Metadata Info:
    • OK becomes Eval: selecting will evaluate the variables in the window
    • Save, Upload & -> becomes Upload options: selecting this will open the Uploader window
    • Apply Metadata Template becomes Copy to Template: selecting this will copy the populated fields on the Info window and Copy them to the Metadata Template
      • Additionally, holding the Control key at the same time will Apply the contents of the Info window to all images selected on the Contact Sheet. In this scenario.
    • Everything from the Metadata Template section above
  • Structured Keywords Panel:
    • Load from Master becomes Merge from Master
    • Add to Master becomes Overwrite Master.

Contact Sheet

With Multiple items selected on the Contact Sheet, holding down the modifier key will perform actions on all selected items, rather than just a single item:

  • Clicking on a tag box: all images in the selection have the same tag value as the photo whose tag was clicked on.
  • Clicking on a rotation hover button will rotate all images in the selection in the same direction.
  • When setting a color class on a photo via the contextual menu will set all selected images (if any) to the same color class.
  • When double-clicking on a thumbnail in a contact sheet will toggle the sense of your preferred double-click action (edit or preview are the two choices.)
  • When using an Edit command on a RAW+JPEG pair: the editor will use the alternate option that what is set on the Launching section of Photo Mechanic's Preferences
  • Navigator/Favorites
    • When double-clicking a saved search in the Favorites will execute the search in a new Contact Sheet.

      When double-clicking a folder in the Favorites or Navigator: the contents of that folder will be added to the current Contact Sheet. 

Preview Window

  • While zoomed into a cropped preview will give you the “hand” cursor which can be used to click and drag the zoomed preview around.
  • While zoomed into a preview will allow the arrow keys to pan the preview around. Adding the shift key (macOS) or control key (Windows) will scroll faster.
  • While moving the scroll wheel on your mouse will zoom in and out of the current preview. Moving the scroll wheel without the Modifier key down will advance through the previews.
  • When clicking on the Remove crop button in the Preview window will remove a constrained crop as well as the crop rectangle.
  • When using an Edit command on a RAW+JPEG pair: the editor will use the alternate option that what is set on the Launching section of Photo Mechanic's Preferences