Important! Critical information about Photo Mechanic Plus and MacOS Sonoma 14.3.

Photo Mechanic Version 5 System Compatibility


Print This Article 

  All Keyboard Shortcuts 




    This message may appear when you upgrade to macOS Mojave and launch Photo Mechanic Version 5 (or earlier). If you select OK, the alert message will disappear, and Photo Mechanic should run as expected. 


Why You See This Message

    While versions of MacOS 10.14 Mojave and below support both 32-bit and 64-bit applications, starting with MacOS 15 Catalina, Apple has removed support for 32-bit applications and will only run 64-bit applications. The warning message is to let you know that Photo Mechanic 5 is a 32-bit application that will no longer work with future versions of MacOS. This alert does not mean Photo Mechanic is incompatible with your computer at this time. However, if your computer is compatible with a newer version of MacOS and you decide to upgrade to that newer version, Photo Mechanic 5 (and all other 32-bit applications) will no longer run on that newer operating system.


    Photo Mechanic Version 5 is compatible with MacOS 10.6.8 (Snow Leopard) through MacOS 10.14 Mojave. Photo Mechanic 5 will not run on MacOS 10.15 Catalina or subsequent versions of MacOS.




Can't find what you were looking for?

Submit a ticket

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry About That!

Let us know how can we improve this article!

Select at least one of the reasons

Feedback sent

We appreciate your effort and will try to improve this article