When you launch Photo Mechanic for the first time you will see an empty Contact Sheet window and the main menu bar at the top of the screen.

Open a new contact sheet

1. Select File > New Contact Sheet Tab (⌘N) to open a blank Contact Sheet within the main window. Then drag and drop a folder into the main part of the Contact Sheet. Any images within that folder will be displayed as a series of thumbnails.

2. Select File > Open Contact Sheet (⌘O) to open an existing folder as a new Contact Sheet. An Open dialog box will appear so you can navigate to the folder you wish to work with.

3. Drag a folder from the desktop onto the Photo Mechanic icon.

You can also open a new contact sheet by double-clicking on a folder in either the Navigator or Favorites panels. 

The Contact Sheet View in Photo Mechanic is the main window to view thumbnails of all of your images, whether you ingest them from your camera or open folders on your hard drive. Contact sheets allow you to rapidly cull for keepers, give star ratings, and more.

Select images

In order to perform operations such as renaming files, moving them to a new location, or Apply a Metadata Template, on a group of images, you will first need to select those images on the Contact Sheet. When an item is selected on the Contact Sheet, the color of the background behind the item will change color (by default, this color is yellow, but this can be changed in Preferences.

There are several ways to Select images:

Selecting a single image: Click on that image

Selecting Multiple images:

  • Hold the Command key (MacOS) or the Control key (Windows) while you click on individual Contact Sheet items. Each item that you click will be added to the selection.
  • To select all items on the current Contact Sheet, press Command+A (MacOS), or Control+(Windows)
  • To select all items between two images on a Contact sheet, click on a single image, and then hold the Shift key while clicking on the last item for that selection.
  • To select all Tagged images, press Command+T (MacOS), or Control+T (Windows)
    • You can Select Images based on other attributes, such as their Star Rating, Color Label, or other Metadata. These options are available in the Edit menu.
  • There are several ways to Search in Photo Mechanic, and some of those methods will change which items are selected on the contact sheet.


Rename files

The filename is always the first text label under the image thumbnail. 

  • Renaming a single item: Double-click on the filename in order to rename it
  • Renaming a selection of items: Make a selection on the Contact Sheet. In the File menu, select Rename Photos or use the keyboard shortcut (Command+on Mac, Ctrl+on Windows).

Context-sensitive menus

Photo Mechanic has context-sensitive menus. Right-clicking (or Ctrl-clicking) on a thumbnail, or selection of thumbnails, brings up a menu of available operations. The same commands can be found in the various menus.

Right-click on a thumbnail to bring up this context-sensitive menu. 


Above the series of thumbnails, you can find controls to switch from selector to loupe cursor. You also have options to sort and filter thumbnails within a contact sheet, such as sorting by image width or displaying only certain star ratings. 

Rotate, Metadata (IPTC) info, and Preview
Courtesy Jason Hill Photography

When you place your cursor over an image without selecting it, you will see an overlay with metadata from the image. You will also see four buttons. The arrows rotate the image. Read more about rotating images. The "i" opens up the Metadata (IPTC) Info tool. Read more about using the Metadata (IPTC) Info tool. The magnifying glass opens up the Preview window. Read more about the Preview window. 

Information under thumbnail images

Each thumbnail image shows the color class (the yellow bar in this example),  tags (the checkbox), and the star rating of the image. You can also change or set these directly in the contact sheet.
If you are using Photo Mechanic Plus, you can also see if an image is currently indexed in a catalog and whether the media is connected (the green dot.) There are up to three lines of text under each thumbnail to give you quick information about each image, such as the name of the file or the folder path. You can customize the text so that it is useful for your workflow. 

Multiple contact sheets

You can have multiple contact sheets open at the same time. They’ll show up as tabs near the top of the screen. You can rearrange tabs by selecting and dragging.  You can also rapidly toggle between open tabs using the keyboard shortcuts:

On macOS:

  • Command-Shift-} move one tab to the right 
  • Command-Shift-{  move one tab to the left

On Windows:

  • Hold down the Control key and use the left or right arrows to navigate. 

Favorites, Navigator, and Tasks

The contact sheet has three main panels: Favorites, Navigator, and Tasks

The Navigator is a view of your computer’s folder system for navigation. 

Favorites are shortcuts to folders you want to reopen in a contact sheet. Add folders to your favorites list by dragging from the navigation area or by right-clicking a folder or tab and selecting Add to Favorites.

Tasks will show progress for Photo Mechanic processes such as ingest and FTP. 

By default Photo Mechanic starts with an empty Contact Sheet window. You can set it to instead present an Open dialog, or you can have it open the last opened Contact Sheet. This setting can be set in the General tab of the Preferences dialog.

Controlling the size of thumbnails

Use the slider above the contact sheet thumbnails to control the size of thumbnails. 

Navigator and Favorites


The Navigator is a view of the hierarchy of folders that can be opened to reach sub-folders. Create a shortcut to the folders you use most often by dragging the desired folder from the Navigator panel into the Favorites panel. 

  • Dragging a folder into the contact sheet area will open it as a contact sheet and replace the current tab. Double click will open a folder as a contact sheet in a new tab. 
  • You can drag images from the contact sheet view onto any folder to move them, or hold the option key to copy them instead of moving them.
  • To remove a Favorite Folder, right-click (Ctrl-click) on it and choose Remove.
  • In the macOS version of Photo Mechanic, you can set a color label for folders by right-clicking (Ctrl-click) and choosing Color Label. 
  • You can add a new folder within an existing folder: An expandable triangle then appears next to the folder.
  • To combine two folders into one contact sheet, right-click (Ctrl-click) the folder you want to add in and select Open in Current Contact Sheet. Option-double-click also opens the folder in the current contact sheet window.
  • To remember the set of folders you are currently browsing as a contact sheet tab use File>Remember Folders as a Favorite... This allows you to set a name for the set of folders and then creates a  multi-folder favorite in the Favorites panel.

Tasks

The tasks pane will show you the progress of longer actions Photo Mechanic is completing, such as memory card ingests, copying files, or FTP uploads. Double-clicking on a progress bar will open a progress dialog and give you options to resolve errors in the task.